Про Magento українською - maque.org.ua

Вітаю. Інсталюючи Magento на локальний сервер AppServ, найімовірніше, Ви матимете кілька повідомлень про неправильне налаштування Вашого сервера, бо налаштування AppServ за промовчанням не є сумісними з Magento 1.4.0.1. У сьогоднішньому винятково текстовому дописі я спробую пояснити, як з цим боротися.

Якщо під час інсталяції Magento на AppServ Ви бачите ось таку помилку:

… то зробити треба таке:

  1. Відкриваємо файл php.ini (він розташований у директорії “Windows” на жорсткому диску С);
  2. Знаходимо рядки з такими ключовими словами
    php_pdo_mysql
    php_mcrypt
  3. Розкоментовуємо їх (тобто видаляємо перед ними ; )
  4. Зберігаємо зміни;
  5. Копіюємо файл libmcrypt.dll (розпакувавши його) до директорії “Windows”;
  6. Перезапускаємо локальний сервер AppServ;
  7. Тепер цих помилок бути не повинно.

Якщо помилки не зникли, скопіюйте ось ці файли (також їх розпакувавши) до директорії “C:\windows\system32”

Якщо маєте ще й таку помилку:

.. то треба встановити AppServ так, аби він підтримував InnoDB.
Ось так ця опція виглядає під час інсталяції AppServ (Enable InnoDB):

Тепер має усе працювати правильно.

Корисні посилання:

1.Встановлюємо Magento на локальний компютер
2.Україномовна спільнота Magento
3.Mcrypt with Appserv on Windows


Колос Віталій
Колос Віталій

Засновник і адмін цього блоґу.